Class 'Imagick' Not Found

less than 1 minute read

I tried to do some Image Magick with PHP recently on an Ubuntu Feisty machine, and even though I had the required package: 'php5-imagick' installed, and I updated my php.ini with imagick.so, I kept getting the error Class 'Imagick' not found. This is how I eventually fixed it.

The idea is to fall back to the good old PECL installation:

sudo aptitude install make php5-dev php-pear
sudo aptitude remove php5-imagick
sudo aptitude install libmagick9-dev
sudo pecl install imagick
sudo /etc/init.d/apache2 restart

And don't forget to put your imagick.so in your php.ini!

Well, that did it for me. No need for a long article this time, but this may help others experiencing similar problems.

Leave a Comment Right Here